Difference between revisions of "Osx installation"

From Pynomo
Jump to: navigation, search
Line 2: Line 2:
  
 
*  Install newest python (2.6.5 tested) [http://www.python.org/ftp/python/2.6.5/python-2.6.5-macosx10.3-2010-03-24.dmg]
 
*  Install newest python (2.6.5 tested) [http://www.python.org/ftp/python/2.6.5/python-2.6.5-macosx10.3-2010-03-24.dmg]
* Download and install latest stable [http://sourceforge.net/projects/numpy/files/NumPy/1.5.0b1/numpy-1.5.0b1-py2.6-python.org.dmg/download Numpy].  
+
* Download and install latest [http://sourceforge.net/projects/numpy/files/NumPy/1.5.0b1/numpy-1.5.0b1-py2.6-python.org.dmg/download Numpy] for python 2.6.  
 
* Download and install latest [http://sourceforge.net/projects/scipy/files/scipy/0.8.0/scipy-0.8.0-py2.6-python.org.dmg/download Scipy]
 
* Download and install latest [http://sourceforge.net/projects/scipy/files/scipy/0.8.0/scipy-0.8.0-py2.6-python.org.dmg/download Scipy]
 
* Install PIL (or skip, probably you won't need it)
 
* Install PIL (or skip, probably you won't need it)

Revision as of 22:29, 5 August 2010

Here I started with fresh OSX 10.6.4 with has preinstalled 2.6.1 (open console and type python).

  • Install newest python (2.6.5 tested) [1]
  • Download and install latest Numpy for python 2.6.
  • Download and install latest Scipy
  • Install PIL (or skip, probably you won't need it)
  • Install MacTex
  • Install PyX
sudo python setup.py install

Run tests on examples directory found in zip-distribution

python GENERATE_ALL.py

If everything ok, you should see pdf documents generated. There are lot's of warnings to be ignored.

Note that for example running scripts in easy-eclipse-for-python do not work due to unknown difference between console running and easy-eclipse-for-python running.

Tested to work 6th August 2010 on by Leif.